Myth II 1.8.0 Public Beta

Talk about anything here.

Moderator: Doobie

Myth II 1.8.0 Public Beta

Postby Melekor » Sat Apr 06, 2013 12:58 am

Project Magma is proud to announce that the official public beta of Myth II version 1.8.0 is now available. Spanning three years of work and including several hundred changes and fixes, 1.8.0 is our biggest update yet!

Download here: http://tain.totalcodex.net/items/show/m ... ublic-beta

Watch the 1.8.0 Promo Video!

Everyone is encouraged to install the beta, and help test the next version of Myth II. We need your help to find any bugs, so that we can fix them before the final version.

A summary of the changes from version 1.7.2 can be viewed here: 1.8.0-Changes-Brief.txt

Please post all bug reports regarding Myth II 1.8.0 in this thread.
User avatar
Melekor
Site Admin
 
Posts: 2064
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta

Postby capital » Sat Apr 06, 2013 1:51 am

Multiplayer checkbox "Allow Old Clients". If unchecked, players on previous versions of the game won't be able to join.


bad, bad, bad idea. More segregation of a dwindling game.

Still no fixes for canonical, and historically relevant games Clue: Knife in the Dark & Myth Chess. Bad.

Decrease in performance on ATI Radeon 9600 graphics w/o disabling opengl. bad.

No update to vTFL patch TFL tagset to correct bugs mentioned in thread on this site. bad.
User avatar
capital
 
Posts: 592
Joined: Wed Mar 31, 2004 9:15 pm

Re: Myth II 1.8.0 Public Beta

Postby punkUser » Sat Apr 06, 2013 2:00 am

capital wrote:bad, bad, bad idea. More segregation of a dwindling game.

It's both necessary (for stuff like KOTM support) and optional (for hosts). It's not like people can't kick/wank based on whatever they want anyways. If you care about segregation, plugins are a way bigger deal than any game options... should all ability for hosts to play what they want be removed perhaps?

capital wrote:Decrease in performance on ATI Radeon 9600 graphics w/o disabling opengl. bad.

Can you be a little more specific here? Specs? Settings? Updated drivers? Also you have access to the tester forums right? Why are you just posting this now?
punkUser
Site Admin
 
Posts: 1040
Joined: Fri Oct 01, 2010 12:58 am

Re: Myth II 1.8.0 Public Beta

Postby Melekor » Sat Apr 06, 2013 2:12 am

capital wrote:
Multiplayer checkbox "Allow Old Clients". If unchecked, players on previous versions of the game won't be able to join.


bad, bad, bad idea. More segregation of a dwindling game.

Still no fixes for canonical, and historically relevant games Clue: Knife in the Dark & Myth Chess. Bad.

Decrease in performance on ATI Radeon 9600 graphics w/o disabling opengl. bad.

No update to vTFL patch TFL tagset to correct bugs mentioned in thread on this site. bad.


Cap, you have had private tester access to these builds for years and not said a single thing. Now minutes after release you post a laundry list of complaints? It's pretty obvious you've been saving these up so you could be a dick about it. :roll:

Even so, if any of your complaints are legit, they will be addressed.
User avatar
Melekor
Site Admin
 
Posts: 2064
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta

Postby £N » Sat Apr 06, 2013 3:35 pm

Interesting. I didn't have time to test or reproduce this, but just now I was in a game where everyone had 1.7.2. I typed something out, and when I hit enter, the host restarted the game (from post to pre), and the text wouldn't send. It just stayed there. I had to delete one letter and type it again, and then it would send. This has never happened to me before, so I'm not sure if it's 1.8 related, or marius related, or what.
£N
 
Posts: 148
Joined: Thu Oct 25, 2007 2:38 pm

Re: Myth II 1.8.0 Public Beta

Postby Pyro » Sat Apr 06, 2013 4:29 pm

capital wrote:More segregation of a dwindling game.


It really isn't that different from adding people to a wanklist to block them from playing your games, except people can't update their way out of someone else's wanklist. Some plugins just break if played in older versions. This was added a year ago to private betas.

capital wrote:Still no fixes for canonical, and historically relevant games Clue: Knife in the Dark & Myth Chess.


We talked about this before more than once, Myth does not break them. Load them in v1.3 and compare with v1.8. The scoring still works the same way. The reason Clue's scoring is wrong is because its design for scoring was flawed. I have since made myself a version that does it right while fixing other minor issues which I might upload in the future. As for MythChess, scoring still works just as it did in 1.3. I see nothing broken about that, however it could do with some minor tweaks.

capital wrote:Decrease in performance on ATI Radeon 9600 graphics w/o disabling opengl.


You never said anything before. Can't fix an issue that doesn't get reported. Need more information to deal with it. What does the log show? Are your drivers updated? Do you have a poweruser file in use? How different is it from 1.7.2 (how big of a FPS difference)?

capital wrote:No update to vTFL patch TFL tagset to correct bugs mentioned in thread on this site.


If 1.8 waited for fixes for all reported issues, it would take longer to be released. Sometimes you just need to save some fixes for the next version. Some issues are really old and therefore have a lower priority than things that might be introduced in the 1.8 betas. Ironically if this got altered, it would require Allow Old Clients as 1.7.2 and older users would not have the updated files.

£N wrote:...text wouldn't send...

Yeah, LN, I've seen it before. It is not new to 1.8.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta

Postby GodzFire » Sat Apr 06, 2013 5:04 pm

capital wrote:Cap, you have had private tester access to these builds for years and not said a single thing. Now minutes after release you post a laundry list of complaints? It's pretty obvious you've been saving these up so you could be a dick about it.


Agreed, that was a real dick move.
RIP: 1998-2013
GodzFire
 
Posts: 1656
Joined: Wed Nov 02, 2005 8:37 pm

Re: Myth II 1.8.0 Public Beta

Postby GodzFire » Sat Apr 06, 2013 6:14 pm

Also just noticed that the 'Allow Old Clients' switch doesn't add an additional text line like all the other game options do if selected. That should probably be added.
RIP: 1998-2013
GodzFire
 
Posts: 1656
Joined: Wed Nov 02, 2005 8:37 pm

Re: Myth II 1.8.0 Public Beta

Postby capital » Sat Apr 06, 2013 7:14 pm

All those points I discussed above have been enumerated many times by me. I spoke to Pyro about them multiple times and said so on Hotline. Selective memories.

The Clue and Chess games no longer work for two reasons one is scoring related code changes and one is scripting related code changes. What is the point of a vTFL change/bug report thread if nothing is done about any of them?

I have found a number of bugs before and reported them, now when I re-report old news... so much for beta testing.

I know people have worked hard on this for many years but Recast bug reports as new news and call people names, gotcha.

The toggle switch to disallow old clients is bad since you have people who don't want or need to upgrade not allowed to join games, Magma's design philosophy had been to allow back portable game joining. The argument that plugins segregate is true, but why introduce yet another barrier?
User avatar
capital
 
Posts: 592
Joined: Wed Mar 31, 2004 9:15 pm

Re: Myth II 1.8.0 Public Beta

Postby ScaryMonster » Sat Apr 06, 2013 7:49 pm

This is like Christmas morning. I am delighted by the update and looking forward to the part beyond-beta where things 'just work'. But at the moment, I have a few issues. I am going to manage my level of verbosity to your requests for more information - just indicate the problem enough so that we know where to go.

I am running a PPC G5 iMac w/ OS 10.5.8.

The PPC build works, but lacks some of the new features, you are probably aware of this and there is probably no plan to make this version identical, but I need to mention it because right now, I'm *assooming*.

The Universal build works and lets me see lots of the improvements, but for one little hitch - I can't see any of the units. Their shadows are rendered. Their selection boxes can be seen and clicked on, but the units themselves are not rendered.

Anything I can do to help resolve this, will be my pleasure.

Thanks,
S.Monster
ScaryMonster
 
Posts: 16
Joined: Wed Dec 19, 2012 8:55 pm

Re: Myth II 1.8.0 Public Beta

Postby Myrd » Sat Apr 06, 2013 8:50 pm

Can you post the contents of your myth_log.txt after starting a game with the Universal build? Does the 1.7.2 universal build work for you? If so, can you post the myth_log.txt from that build too?
Myrd
Site Admin
 
Posts: 3646
Joined: Fri Mar 19, 2004 10:17 pm

Re: Myth II 1.8.0 Public Beta

Postby Pyro » Sat Apr 06, 2013 8:58 pm

capital wrote:Selective memories.


You skipped my earlier post. Yes you have mentioned the Clue/Chess issues which do not exist (try them in 1.3), but everything else you said you have never brought up before.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta

Postby Myrd » Sat Apr 06, 2013 8:58 pm

capital wrote:The Clue and Chess games no longer work for two reasons one is scoring related code changes and one is scripting related code changes. What is the point of a vTFL change/bug report thread if nothing is done about any of them?


I'm not sure about Chess, but I dug up the thread about Pyro's investigation of the Clue issues, here's what he says (on the Build 406 thread in private testers forum):

Pyro wrote:Yeah, I mentioned its broken in 1.3 as well and that it can be fixed mapmaking wise. There was another issue he had on Clue. That sometimes by using the secret passages, you sometimes get eliminated. However, this is also a mapmaking mistake since teams only have one unit and having it invisible for a time can make the map think you are out of units. I was thinking of making a fixed version of Clue after I noticed it was always broken.


So sounds like the issues on Clue have always been there and require mapmaking changes to resolve. By the way, 1.8 includes a new mapmaking feature to hide unit controller's names (since larger screen resolutions make the technique used in Clue of adding spaces not work). So if someone were to make a new release of Clue, they can fix that as well.
Myrd
Site Admin
 
Posts: 3646
Joined: Fri Mar 19, 2004 10:17 pm

Re: Myth II 1.8.0 Public Beta

Postby GodzFire » Sat Apr 06, 2013 9:16 pm

The toggle switch to disallow old clients is bad since you have people who don't want or need to upgrade not allowed to join games, Magma's design philosophy had been to allow back portable game joining. The argument that plugins segregate is true, but why introduce yet another barrier?


Did you read all the changes that were made between 1.7.2 and 1.8? Some of them require that everyone is running 1.8 to work. There's no change for not letting older versions play than it used to be with other previous releases, the only difference is now there's a button to help enforce only wanting people with 1.8 in your games.

If people don't want to upgrade, frankly that's their problem. There's a reason why public betas are released instead of just the final, to shake out any issues from a wider variety of players and get feedback from things that are still wrong. If people have a problem with 1.8 then they need to report it, otherwise it's too bad so sad for them. Laziness isn't an excuse.
RIP: 1998-2013
GodzFire
 
Posts: 1656
Joined: Wed Nov 02, 2005 8:37 pm

Re: Myth II 1.8.0 Public Beta

Postby punkUser » Sat Apr 06, 2013 9:26 pm

capital wrote:The toggle switch to disallow old clients is bad since you have people who don't want or need to upgrade not allowed to join games, Magma's design philosophy had been to allow back portable game joining. The argument that plugins segregate is true, but why introduce yet another barrier?

I'd agree to that if 1.8 simply was not backwards compatible at all, but it's an option for the host... if they want to allow older clients (and usually they will), they can. If they have a good reason to not allow them (and would presumably kick them otherwise), this solutions lets people know why they would otherwise have been kicked and where to go to get the new version if they want to join. Seems ideal to me.
punkUser
Site Admin
 
Posts: 1040
Joined: Fri Oct 01, 2010 12:58 am

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests