Myth II 1.8.0 Public Beta 2

Talk about anything here.

Moderator: Doobie

Re: Myth II 1.8.0 Public Beta 2

Postby Melekor » Thu May 23, 2013 2:58 pm

GodzFire wrote:With Macs, there's much less chance of it being outdated graphics drivers since the hardware (Mac) and software (OSX) are so closely linked.

Actually there's much more chance of the drivers being outdated, since apple updates drivers much less frequently than the IHVs, if they update them at all. But I digress...

GodzFire wrote:what model Mac do you got? When you have access to it again, find out what card that thing is running.

That will be in the myth log, no need to look it up separately.
User avatar
Melekor
Site Admin
 
Posts: 2064
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby GodzFire » Thu May 23, 2013 4:58 pm

Of course they update them. Happens in both major .x updates and in minor .x.x ones too.
RIP: 1998-2013
GodzFire
 
Posts: 1656
Joined: Wed Nov 02, 2005 8:37 pm

Re: Myth II 1.8.0 Public Beta 2

Postby myth2 » Fri May 24, 2013 11:27 pm

FRESH CRASHLOG *steaming even*
Attachments
myth_crashlog- 2013-05-24 21.24.27.txt
hot crashlog
(7.73 KiB) Downloaded 56 times
myth2
 
Posts: 6
Joined: Wed May 15, 2013 12:11 am

Re: Myth II 1.8.0 Public Beta 2

Postby Melekor » Sat May 25, 2013 12:14 pm

myth2 wrote:FRESH CRASHLOG *steaming even*

Still crashing in the graphics driver. Since updating drivers didn't help, I can suggest some possible workarounds:
-You could try using DirectX instead
-You could try editing your poweruser.txt as described here: viewtopic.php?f=2&t=6240&p=63027&hilit=poweruser#p63027
User avatar
Melekor
Site Admin
 
Posts: 2064
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby Arzenic » Sat May 25, 2013 12:42 pm

a few bugs i have found out:

sometimes the myth lobby stops updating. so for example the game information or the players in lobby don't show correctly. also player stats etc don't load. the only way to fix it is to leave and re-join the room. This has happened to me about 4-5 times since 1.8.0 beta 1. I often leave myth open in the background for several hours so it is very difficult to say when the updating stops, making re-producing also quite difficult.

another thing: when watching recordigs, units sunk in deep water do not show on overview map.

information on my setup:
windows 7 64-bit
nvidia GPU with latest drivers
open GL 4.3 rendering
use multiple processors/cores is selected
myth in windowed mode
Arzenic
 
Posts: 10
Joined: Sun May 03, 2009 4:10 pm

Re: Myth II 1.8.0 Public Beta 2

Postby myth2 » Sat May 25, 2013 1:17 pm

ok, another crash..

Most likely the same as before, but what the hell.
Attachments
myth_crashlog- 2013-05-25 11.15.15.txt
crashed
(2.79 KiB) Downloaded 42 times
myth2
 
Posts: 6
Joined: Wed May 15, 2013 12:11 am

Re: Myth II 1.8.0 Public Beta 2

Postby myth2 » Sat May 25, 2013 1:43 pm

How about a DirectX11 crashlog?
Attachments
myth_crashlog- 2013-05-25 11.41.47.txt
DirectX11 crashlog
(5.18 KiB) Downloaded 44 times
myth2
 
Posts: 6
Joined: Wed May 15, 2013 12:11 am

Re: Myth II 1.8.0 Public Beta 2

Postby punkUser » Sat May 25, 2013 1:50 pm

Yeah definitely graphics driver crashes. I talked to him on Mnet and he has updated his drivers so at this point the only options may be to try D3D, or perhaps OpenGL with UseShaders=false (as Melekor described above) to see if they tend to be less crashy. Otherwise there is always software...
punkUser
Site Admin
 
Posts: 1040
Joined: Fri Oct 01, 2010 12:58 am

Re: Myth II 1.8.0 Public Beta 2

Postby killerking » Sun May 26, 2013 5:33 am

Hello,

Yesterday I heard a strange sound while playing Myth II, turning ambient sounds of helped to get rid of it.
Also, I found at that the sound option openAL results in NO SOUND AT ALL.

I wasn't able to reproduce the strange sound today, but maybe other people have heard this as well?

Here's my myth log:
2013-05-26 12:27:39
Myth II Build 420 running under Modern Windows 6.010000 ----------------------------------------------
Loading poweruser.txt... not found.
DEBUG: Updating monolithic tag cache:
Initial count: 87
Number removed: 0
Number added: 2
New count: 89
DEBUG: Adding 15 monolithic tags:
small install
medium install
large install
international small install
international large install
Patch 1.2
Patch MariusNet
Patch 1.3
Patch 1.4
Patch 1.5
Patch 1.8 Interface
Patch 1.7 Templates
Green Berets Detail Textures
Magma - Bungie Map Textures v1
MWC Detail Textures
Scanning for software devices...
Found 1 to use
Scanning for Direct3D devices...
Found 1 to use
Scanning for DirectX 11 devices...
Found adapter: AMD Radeon HD 7520G
Found 1 to use
Scanning for 3Dfx devices...
Found 0 to use
Scanning for OpenGL devices...
Found 1 to use
AMD Radeon HD 7520G | ATI Technologies Inc. | OpenGL 4.2
Initializing sound with DirectSound...
Initialized for DirectSound3D using COM
DirectSound initialized successfully.
Establishing connection with metaserver at myth.mariusnet.com:6321...
Connected.
DEBUG: Adding 1 monolithic tags:
Myth HD Total Conversion v1
Running OpenGL 4.2 at 1366 x 768
Starting mesh "Gyre in the Wabe" with 1 plugin...
Myth HD Total Conversion v1
Using 1.8.0 BETA 2 gameplay...
OpenGL: Initialized with ErasePreviousFrame=1, MaxAnisotropy=8, MSAASamples=1, UseDepthTest=1, UseMipMaps=1, UseNPO2Textures=1, UseShaders=1, UpdateCMapChunked=1, UseCMapTiles=1, UseAppleClientStorage=0
Quitting networked game...
Disconnecting from metaserver.
DEBUG: Removing 1 monolithic tags:
Myth HD Total Conversion v1
Initializing sound with OpenAL...
OpenAL: OpenAL library not found. Sound will be disabled.
OpenAL initialization failed.
Establishing connection with metaserver at myth.mariusnet.com:6321...
Connected.
Disconnecting from metaserver.
Establishing connection with metaserver at myth.mariusnet.com:6321...
Connected.
DEBUG: Adding 1 monolithic tags:
Myth HD Total Conversion v1
Running OpenGL 4.2 at 1366 x 768
Starting mesh "Gyre in the Wabe" with 1 plugin...
Myth HD Total Conversion v1
Using 1.8.0 BETA 2 gameplay...
OpenGL: Initialized with ErasePreviousFrame=0, MaxAnisotropy=8, MSAASamples=1, UseDepthTest=1, UseMipMaps=1, UseNPO2Textures=1, UseShaders=1, UpdateCMapChunked=1, UseCMapTiles=1, UseAppleClientStorage=0
killerking
 
Posts: 288
Joined: Tue Jul 01, 2008 3:57 am
Location: The Netherlands

Re: Myth II 1.8.0 Public Beta 2

Postby ryancarlo0105 » Sun May 26, 2013 9:17 am

My Beta 2 has expired . when will the latest come out ?
:)
ryancarlo0105
 
Posts: 20
Joined: Fri Apr 12, 2013 8:00 am

Re: Myth II 1.8.0 Public Beta 2

Postby killerking » Sun May 26, 2013 10:10 am

Okay, I had the sound problem again when I watched one of yesterday's replay's (gimble with ambient sounds on). Happened on 1.7.2

2013-05-26 17:01:21
Myth II Build 374 running under Modern Windows 6.010000 ----------------------------------------------
Loading poweruser.txt... not found.
Scanning for software devices...
Found 1 to use
Scanning for Direct3D devices...
Found 1 to use
Scanning for DirectX 11 devices...
Found adapter: AMD Radeon HD 7520G
Found 1 to use
Scanning for 3Dfx devices...
Found 0 to use
Scanning for OpenGL devices...
Found 1 to use
AMD Radeon HD 7520G | ATI Technologies Inc. | OpenGL 4.2
Initialized for DirectSound3D using COM
INFO: set process affinity mask to 0x00000003
Error: Data Corrupted in .\Myth2Code\tag_files\tag_files.c, line #3552: the monolithic file 'plugins\readme brokenarrow' has no header
Loading Patch Files...
Patch 1.2
Patch MariusNet
Patch 1.3
Patch 1.4
Patch 1.4 Interface
Patch 1.5
Patch 1.7 Templates
Green Berets Detail Textures
Magma - Bungie Map Textures v1
MWC Detail Textures
Loading Patch Files Succeeded
Establishing connection with metaserver at myth.mariusnet.com:6321...
Connected.
Disconnecting from metaserver.
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\chimera04thearcher easier way'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'chimera04thearcher easier way'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\chimera05themessengerkillall'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'chimera05themessengerkillall'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 13.52.51 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 13.52.51 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.22.28 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.22.28 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.32.02 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.32.02 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.52.07 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.52.07 2009'
Replaying film "Netgame- May 23 23.43.18 2013" ...
Running OpenGL at 1366 x 768
Starting mesh "Gimble in the Wabe"...
Using 1.7.2 gameplay...
OpenGL: initialized with ErasePreviousFrame=0, Use32BitTextures=1, UseAppleClientStorage=1, UseDepthTest=1, UseShaders=1, UpdateCMapChunked=1
Quitting replay...
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\chimera04thearcher easier way'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'chimera04thearcher easier way'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\chimera05themessengerkillall'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'chimera05themessengerkillall'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 13.52.51 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 13.52.51 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.22.28 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.22.28 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.32.02 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.32.02 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #2663: couldn't read #2600 bytes from offset #64 in local tag 'recordings\Netgame- May 3 14.52.07 2009'
Error: File system Read in .\Myth2Code\tag_files\tag_files.c, line #1216: single_file_read() failed in tag_file_read()
Error: File system Read in .\Myth2Code\recording.c, line #1638: couldn't read the header for recording 'Netgame- May 3 14.52.07 2009'
Closing Myth.
killerking
 
Posts: 288
Joined: Tue Jul 01, 2008 3:57 am
Location: The Netherlands

Re: Myth II 1.8.0 Public Beta 2

Postby Melekor » Wed May 29, 2013 1:23 pm

Unstickying now that final is out.

Arzenic wrote:sometimes the myth lobby stops updating.

another thing: when watching recordigs, units sunk in deep water do not show on overview map.


Unfortunately we didn't get around to fixing either of these in time for the final version, but we'll keep them in mind for 1.8.1.

For the lobby thing, we don't know why it happens but the pattern seems to be that it is more likely when the 'use multicore' preference is selected. You could try unchecking that and see if it stops happening.
User avatar
Melekor
Site Admin
 
Posts: 2064
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby punkUser » Wed May 29, 2013 4:16 pm

Arzenic wrote:sometimes the myth lobby stops updating.

To get a bit more info, do you mean everything stops updating including the chat, or that some game or room count or similar lingers? Does changing rooms help or does it disconnect you?
punkUser
Site Admin
 
Posts: 1040
Joined: Fri Oct 01, 2010 12:58 am

Re: Myth II 1.8.0 Public Beta 2

Postby Arzenic » Wed May 29, 2013 11:21 pm

punkUser wrote:To get a bit more info, do you mean everything stops updating including the chat, or that some game or room count or similar lingers? Does changing rooms help or does it disconnect you?


The whole information you see in lobby "freezes" i.e. game info, players in room, chat, etc...

as I said leaving and re-joining the room fixes it
Arzenic
 
Posts: 10
Joined: Sun May 03, 2009 4:10 pm

Re: Myth II 1.8.0 Public Beta 2

Postby Pyro » Thu May 30, 2013 2:08 am

You are logged in when this happens right? Not as a guest? I know guest accounts on Mnet have this issue and I think that is a metaserver side problem. If this happens while logged in, then that sounds like a possible Myth issue. Did you go to preferences and disable "Use Multiple Processors/Cores" to see if it helps?
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests