Myth II 1.8.0 Public Beta 2

Talk about anything here.

Moderator: Doobie

Re: Bug report: Myth II 1.8.0 Public Beta 2

Postby Melekor » Fri May 10, 2013 3:38 pm

carnage99 wrote:With 1.8 Beta 2 (newer Mac) I see black rectangles where my units are. If I move the camera one or two units may draw correctly, but the majority are failing to render. This happens with regular and plugin maps/units


Can you try the following: In your preferences folder, create a txt file called poweruser.txt, with the following contents:
Code: Select all
[Renderer.OpenGL]
UseMipMaps=False

Then start myth again. Let us know if it fixes the problem. If it doesn't fix the problem, please post your myth log again to confirm the setting was applied correctly.
User avatar
Melekor
Site Admin
 
Posts: 2081
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby Industry » Fri May 10, 2013 10:43 pm

Sadly beta 2 did not resolve my problem with dropping frame rate. Exact same thing happens.
Attachments
poweruser.txt
(74 Bytes) Downloaded 79 times
myth_log.txt
(1.79 KiB) Downloaded 73 times
Industry
 
Posts: 298
Joined: Fri Mar 19, 2004 3:47 pm
Location: Alaska

Re: Myth II 1.8.0 Public Beta 2

Postby punkUser » Fri May 10, 2013 11:14 pm

Can you post a 1.7.2 log of when it's fast, as well as letting us know some specific FPS numbers for the two versions in reproducible situations (say the start of willow creek or something before you move the camera)?
punkUser
Site Admin
 
Posts: 1048
Joined: Fri Oct 01, 2010 12:58 am

Re: Myth II 1.8.0 Public Beta 2

Postby DominicWhite » Sat May 11, 2013 10:01 am

Great work on v1.8.0 so far - it seems pretty universally great. I did just notice one small tagset-pairing oversight.

While it seems to identify correctly which tagsets go with which maps, Green Berets V2 (http://tain.totalcodex.net/items/show/green-berets-pack) doesn't seem to auto-pair the map pack and the tagset.

I'm on Windows 7 x64, if that makes any difference.

Also, less of a bug report and more of a feature request - it's probably considered cheating (so perhaps make it a cheat-code?), but given how high-res modern monitors are, I'd love to use the additional zoom levels from replay mode during gameplay. Solo, most likely, although a tickbox to enable it in multiplayer might be interesting.

Edit: A second small feature request just sprang to mind - if you can have it automatically load the correct tilesets for certain campaigns, an option to have it load the matching interface file might be nice. Green Berets, Mazzarin's Demise, etc. Just an idea
DominicWhite
 
Posts: 1
Joined: Sat May 11, 2013 9:57 am

Re: Myth II 1.8.0 Public Beta 2

Postby Melekor » Sat May 11, 2013 3:14 pm

Hi Dominic, thanks for the feedback. Green Berets will be added to the list of hardcoded campaigns for 1.8 final.

Your feature suggestions are good ones which we've thought of also. 1.8 is feature locked now but perhaps these can be added to 1.8.1 or future versions.
User avatar
Melekor
Site Admin
 
Posts: 2081
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby Industry » Sat May 11, 2013 5:31 pm

punkUser wrote:Can you post a 1.7.2 log of when it's fast, as well as letting us know some specific FPS numbers for the two versions in reproducible situations (say the start of willow creek or something before you move the camera)?


I posted in the beta 1 test with all these things. My frame rate drops as low at 10, but then it will just right back up again to 60 (which is around where it is usually). In beta 1 I used a film from a Mazzarin's Demise game. The specific instance I pointed to was a Paladin's heal burst (which I think are projectiles). It only happens when things get busy. It's hard to get a good read of how low the frame rate drops and how long it stays there, since it drops and jumps back up and drops again all in the space of seconds.
Industry
 
Posts: 298
Joined: Fri Mar 19, 2004 3:47 pm
Location: Alaska

Re: Myth II 1.8.0 Public Beta 2

Postby Myrd » Sat May 11, 2013 8:25 pm

Industry wrote:
punkUser wrote:Can you post a 1.7.2 log of when it's fast, as well as letting us know some specific FPS numbers for the two versions in reproducible situations (say the start of willow creek or something before you move the camera)?


I posted in the beta 1 test with all these things. My frame rate drops as low at 10, but then it will just right back up again to 60 (which is around where it is usually). In beta 1 I used a film from a Mazzarin's Demise game. The specific instance I pointed to was a Paladin's heal burst (which I think are projectiles). It only happens when things get busy. It's hard to get a good read of how low the frame rate drops and how long it stays there, since it drops and jumps back up and drops again all in the space of seconds.


What's your memory use like? Could it be that with 1G ram, your system is running low on RAM during those moments? What's your texture cache setting like? Does increasing or decreasing it help?

Any chance you could try some intermediate private beta builds for us and identify which build introduced the problem?
Myrd
Site Admin
 
Posts: 3683
Joined: Fri Mar 19, 2004 10:17 pm

Re: Myth II 1.8.0 Public Beta 2

Postby Industry » Tue May 14, 2013 12:49 am

My texture cache usually lives at 144MB but I lowered it to as low as 32MB and still had problems. I'll grab the previous privates and try the same test.
Industry
 
Posts: 298
Joined: Fri Mar 19, 2004 3:47 pm
Location: Alaska

Re: Myth II 1.8.0 Public Beta 2

Postby paladin MAIK » Tue May 14, 2013 5:58 am

I do not know if there was a question or not, "How many units will support the card?"

In version 1.7.2 Maximum number of soldiers on the map was 400 :|
Image
Last 3 project frozen for an indefinite period
User avatar
paladin MAIK
 
Posts: 328
Joined: Mon Aug 06, 2012 12:31 am
Location: (RU)

Re: Myth II 1.8.0 Public Beta 2

Postby punkUser » Tue May 14, 2013 10:44 am

paladin MAIK wrote:In version 1.7.2 Maximum number of soldiers on the map was 400 :|

That limit has not changed in 1.8.
punkUser
Site Admin
 
Posts: 1048
Joined: Fri Oct 01, 2010 12:58 am

Re: Myth II 1.8.0 Public Beta 2

Postby myth2 » Wed May 15, 2013 12:39 am

OK, here is a *fresh* crash log for beta 2 (fixed with the correct log now!)

Since the above log proved useless, now includes older beta1 logs for improved pleasure!
Last edited by myth2 on Sat May 25, 2013 12:10 pm, edited 3 times in total.
myth2
 
Posts: 6
Joined: Wed May 15, 2013 12:11 am

Re: Myth II 1.8.0 Public Beta 2

Postby Pyro » Wed May 15, 2013 1:16 am

That log shows you loaded 1.7.2, and not the 1.8.0 beta. Also, it does not show a crash. Run "Myth II 1.8 Public Beta 2" instead of "Myth II" to run the beta.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4624
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta 2

Postby Melekor » Wed May 15, 2013 2:15 am

myth2 wrote:Since the above log proved useless, now includes older beta1 logs for improved pleasure!

The crashlogs indicate that the crash is happening inside your graphics driver. I see you have an intel graphics chipset, so check out this page: http://www.intel.com/p/en_US/support/detect/graphics to get the latest drivers for your intel hardware. Updating the drivers should probably fix the problem, let us know if it doesn't.
User avatar
Melekor
Site Admin
 
Posts: 2081
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

Re: Myth II 1.8.0 Public Beta 2

Postby Industry » Sun May 19, 2013 2:09 am

Happens on 419.
Industry
 
Posts: 298
Joined: Fri Mar 19, 2004 3:47 pm
Location: Alaska

Re: Myth II 1.8.0 Public Beta 2

Postby Industry » Sun May 19, 2013 2:51 am

418, 415, 414. Will try 413 tomorrow. Don't remember it happening on 412.
Industry
 
Posts: 298
Joined: Fri Mar 19, 2004 3:47 pm
Location: Alaska

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: Bing [Bot] and 5 guests