Myth II 1.8.0 Public Beta

Talk about anything here.

Moderator: Doobie

Re: Myth II 1.8.0 Public Beta

Postby ScaryMonster » Sat Apr 06, 2013 9:52 pm

Myrd wrote:Can you post the contents of your myth_log.txt after starting a game with the Universal build? Does the 1.7.2 universal build work for you? If so, can you post the myth_log.txt from that build too?


myth_log.txt for 1.8ß
2013-04-06 22:35:11
Myth II |iUniversal|p Build 417 running under MacOS 1058 (PPC) ----------------------------------------------
Loading poweruser.txt... not found.
DEBUG: Updating monolithic tag cache:
Initial count: 278
Number removed: 0
Number added: 0
New count: 278
DEBUG: Adding 13 monolithic tags:
small install
medium install
large install
international small install
international large install
Patch 1.2
Patch MariusNet
Patch 1.3
Patch 1.4
Patch 1.5
Patch 1.8 Interface
Patch 1.7 Templates
Green Berets Detail Textures
Scanning for software devices...
Found 1 to use
Scanning for OpenGL devices...
Found 1 to use
ATI Radeon X600 XT OpenGL Engine | ATI Technologies Inc. | OpenGL 2.0
Warning: Unable to find cutscene 'prologue.smk'.
DEBUG: Adding 2 monolithic tags:
Magma - Five Legends TFL
Magma - The Fallen Levels v2
DEBUG: Removing 2 monolithic tags:
Magma - Five Legends TFL
Magma - The Fallen Levels v2
Running OpenGL 2.0 at 1680 x 1050
Starting mesh "Willow Creek"...
Using 1.8.0 BETA gameplay...
OpenGL: Initialized with ErasePreviousFrame=1, MaxAnisotropy=8, MSAASamples=1, UseDepthTest=1, UseMipMaps=1, UseNPO2Textures=1, UseShaders=1, UpdateCMapChunked=1, UseCMapTiles=1, UseAppleClientStorage=1
Quitting single player game...
Warning: Unable to find cutscene 'prologue.smk'.
Closing Myth.

myth_log.txt for 1.7.2
2013-04-06 22:20:37
Myth II 32-Bit |iUniversal|p Build 374 running under MacOS 1058 (PPC) ----------------------------------------------
Loading poweruser.txt... not found.
Scanning for software devices...
Found 1 to use
Scanning for OpenGL devices...
Found 1 to use
ATI Radeon X600 XT OpenGL Engine | ATI Technologies Inc. | OpenGL 2.0
Loading Patch Files...
Patch 1.2
Patch MariusNet
Patch 1.3
Patch 1.4
Patch 1.4 Interface
Patch 1.5
Patch 1.7 Templates
Green Berets Detail Textures
Loading Patch Files Succeeded
Warning: Unable to find cutscene 'prologue.mov'.
Running OpenGL at 1680 x 1050
Starting mesh "Willow Creek"...
Using 1.7.2 gameplay...
OpenGL: initialized with ErasePreviousFrame=0, Use32BitTextures=1, UseAppleClientStorage=1, UseDepthTest=1, UseShaders=1, UpdateCMapChunked=1
Warning: Unable to find cutscene 'prologue.mov'.
Closing Myth.

myth_log.txt for 1.8ß (PPC)
2013-04-07 02:35:10
Myth II Build 417 running under MacOS 1058 (PPC) ----------------------------------------------
Loading poweruser.txt... not found.
DEBUG: Updating monolithic tag cache:
Initial count: 278
Number removed: 0
Number added: 0
New count: 278
DEBUG: Adding 13 monolithic tags:
small install
medium install
large install
international small install
international large install
Patch 1.2
Patch MariusNet
Patch 1.3
Patch 1.4
Patch 1.5
Patch 1.8 Interface
Patch 1.7 Templates
Green Berets Detail Textures
Scanning for software devices...
Found 1 to use
Scanning for OpenGL devices...
Found 1 to use
ATI Radeon X600 XT OpenGL Engine | ATI Technologies Inc. | OpenGL 2.0
Warning: Unable to find cutscene 'prologue'.
Running OpenGL 2.0 at 1680 x 1050
Starting mesh "Willow Creek"...
Using 1.8.0 BETA gameplay...
OpenGL: Initialized with ErasePreviousFrame=0, MaxAnisotropy=8, MSAASamples=1, UseDepthTest=1, UseMipMaps=0, UseNPO2Textures=0, UseShaders=0, UpdateCMapChunked=1, UseCMapTiles=0, UseAppleClientStorage=1
Warning: Unable to find cutscene 'prologue'.
Closing Myth.
Last edited by ScaryMonster on Sun Apr 07, 2013 1:48 am, edited 1 time in total.
ScaryMonster
 
Posts: 16
Joined: Wed Dec 19, 2012 8:55 pm

Re: Myth II 1.8.0 Public Beta

Postby Myrd » Sat Apr 06, 2013 9:56 pm

And 1.7.2 Universal build doesn't have the issue, right?

EDIT: Also, can you post a mythlog from 1.8 PPC build as well?
Myrd
Site Admin
 
Posts: 3649
Joined: Fri Mar 19, 2004 10:17 pm

Re: Myth II 1.8.0 Public Beta

Postby capital » Sat Apr 06, 2013 11:58 pm

capital wrote:
Multiplayer checkbox "Allow Old Clients". If unchecked, players on previous versions of the game won't be able to join.


bad, bad, bad idea. More segregation of a dwindling game.

Still no fixes for canonical, and historically relevant games Clue: Knife in the Dark & Myth Chess. Bad.

Decrease in performance on ATI Radeon 9600 graphics w/o disabling opengl. bad.

No update to vTFL patch TFL tagset to correct bugs mentioned in thread on this site. bad.


The good news is that 1.8 fixes the scripting coding bug that killed off non-host players in Chess & Clue, this was just verified w/ Myrd but hidden in a extended changelog. Eternally grateful for this fix, I am sure a lot people will be happy that these games play as originally scripted.

The Decrease in FPS can't be resolved thru driver updates, but perhaps a hack w/ poweruser mods:

[Renderer.OpenGL]
UseShaders=False
UseCMapTiles=False
User avatar
capital
 
Posts: 592
Joined: Wed Mar 31, 2004 9:15 pm

Re: Myth II 1.8.0 Public Beta

Postby paladin MAIK » Sun Apr 07, 2013 12:02 am

Somebody explain to me what an option means 32 bits :?:
Image
Last 3 project frozen for an indefinite period
User avatar
paladin MAIK
 
Posts: 328
Joined: Mon Aug 06, 2012 12:31 am
Location: (RU)

Re: Myth II 1.8.0 Public Beta

Postby Pyro » Sun Apr 07, 2013 12:09 am

If you click on the "?" button in preferences, it opens the PDF file (must have Adobe Reader) that shows a description for each item including 32bit.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta

Postby paladin MAIK » Sun Apr 07, 2013 12:13 am

Pyro wrote:If you click on the "?" button in preferences, it opens the PDF file (must have Adobe Reader) that shows a description for each item including 32bit.


Strangely, I did not open. Then take a look now PDF file highlighted.
(PDF reader I have)
Image
Last 3 project frozen for an indefinite period
User avatar
paladin MAIK
 
Posts: 328
Joined: Mon Aug 06, 2012 12:31 am
Location: (RU)

Re: Myth II 1.8.0 Public Beta

Postby Pyro » Sun Apr 07, 2013 12:17 am

What did you install? Windows or Mac? Or was it a manual install? the PDF has to be in your myth 2 folder for that button to work.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta

Postby ScaryMonster » Sun Apr 07, 2013 2:08 am

Myrd wrote:And 1.7.2 Universal build doesn't have the issue, right?

EDIT: Also, can you post a mythlog from 1.8 PPC build as well?



Done (added as edit to above).
Neither 1.72 Universal nor 1.8ß PPC version have this issue.
ScaryMonster
 
Posts: 16
Joined: Wed Dec 19, 2012 8:55 pm

Re: Myth II 1.8.0 Public Beta

Postby Mything persons » Sun Apr 07, 2013 2:10 am

Does this work with vTFL?
Mything persons
 
Posts: 3
Joined: Sun Apr 07, 2013 2:07 am

Re: Myth II 1.8.0 Public Beta

Postby GodzFire » Sun Apr 07, 2013 11:12 am

The Decrease in FPS can't be resolved thru driver updates,


Hold on there, if I recall, you were never able to figure out how to install the drivers on your computer (unless I missed part of the chat last night, if so apologies on my end), so you really can't say that. There were driver updates for your card.
RIP: 1998-2013
GodzFire
 
Posts: 1660
Joined: Wed Nov 02, 2005 8:37 pm

Re: Myth II 1.8.0 Public Beta

Postby Myrd » Sun Apr 07, 2013 11:42 am

ScaryMonster wrote:
Myrd wrote:And 1.7.2 Universal build doesn't have the issue, right?

EDIT: Also, can you post a mythlog from 1.8 PPC build as well?



Done (added as edit to above).
Neither 1.72 Universal nor 1.8ß PPC version have this issue.


Okay. Can you try the following:

Create a file called poweruser.txt in your preferences folder and put it in the following:

Code: Select all
[Renderer.OpenGL]
UseShaders=False
UseMipMaps=False
UseNPO2Textures=False


And let us know if this makes the 1.8 UB work for you. If it does, we'll be tweaking 1.8 to make this default for configs such as yours.
Myrd
Site Admin
 
Posts: 3649
Joined: Fri Mar 19, 2004 10:17 pm

Re: Myth II 1.8.0 Public Beta

Postby Pyro » Sun Apr 07, 2013 12:31 pm

Mything persons wrote:Does this work with vTFL?


Why wouldn't it? The option didn't get removed.
User avatar
Pyro
Bug Finder Extraordinaire
 
Posts: 4622
Joined: Sun Mar 21, 2004 2:14 pm
Location: Texas

Re: Myth II 1.8.0 Public Beta

Postby pallidice » Sun Apr 07, 2013 2:19 pm

pyro told me to post this. In 1.7.2 the option for open GL was available, now in 1.8 the only option i get is software screen#1. He demanded we get open GL to work with pallidices crappy computer.

specs: PowerPC G4 dual 867Mhz
1mb L3 cache per processer
MacOSX 10.4.11
Memeory- 1.75GB DDR SDram
Graphics- GeForce4 MX
Bus: apg
V-Ram 32 megs


Thx in advance
Attachments
myth_log.txt
(738 Bytes) Downloaded 36 times
Pallidice
pallidice
 
Posts: 21
Joined: Fri Mar 23, 2007 7:58 pm
Location: canada

Re: Myth II 1.8.0 Public Beta

Postby pallidice » Sun Apr 07, 2013 2:42 pm

is this 1.8
Attachments
myth_log.txt
(1.08 KiB) Downloaded 29 times
Pallidice
pallidice
 
Posts: 21
Joined: Fri Mar 23, 2007 7:58 pm
Location: canada

Re: Myth II 1.8.0 Public Beta

Postby Melekor » Sun Apr 07, 2013 6:32 pm

So just to clarify Pallidice - OpenGL not only shows up in the list in 1.7.2, but it works fine for playing games as well? Do detail textures work?
User avatar
Melekor
Site Admin
 
Posts: 2072
Joined: Sat May 01, 2004 12:10 am
Location: British Columbia

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest